How-To Disable DXVA for ATI Cards to Fix Pixilation and Corruption in High Bitrate h264 Files

I originally posted this as a reply on The Green Button:

And now I’m posting it here for mostly personal reference.

I have problems with at least four 1080p and three 720p h264 files. The problem is basically what netscan02 said: ATI cards have issues with some higher bitrate files. I'm using the default video driver that comes on the Windows 7 DVD (which is apparently the same as the driver in the "Catalyst 9.5" package). I have not tried any of the newer Catalyst releases as I would rather let Windows Update handle driver updates instead of chasing new Catalyst releases.

My "solution" ended up being to disable DXVA for h264 using "DXVA Checker":

All you have to do is download DXVA Checker, extract it somewhere, run it, hit the little button in the upper right corner under the close button (X), hit Video Acceleration Settings (or CTRL-V) and toggle "HWUVD_DisableH264". There should be a check mark in the checkbox to the left and a "1" in the Value column if you clicked in the right place.

Keep in mind that this disables DXVA for h264 streams so you're going to see quite a bit of CPU usage when playing ANY h264 files from now on. This may not be an issue as DXVA gets disabled if your files have subtitle streams anyway.

There may be other solutions but this one gets your stuff working without mucking about with 3rd party nonsense. (Well other than our favorite trilogy of Haali (for MKV's), AC3Filter (for DTS) and VSFilter (for subtitles).)